API-CONNECT · CVE-2026-17404 · Infrastructure
FIX → 12.1.1.3 · 10.0.8.13
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 have a server-side request forgery flaw. A remote attacker with a valid account can make the server fetch internal resources and leak sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-managed IBM API Connect deployments on 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. An attacker needs a valid account (low privileges) and can make the server send requests to internal resources and read back sensitive information. IBM's CVE text does not name the endpoint or feature. Deployments already on 10.0.8.13 or 12.1.1.3 can skip it.
Not affected if fixed-version-installed, version-outside-range
Who cares ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12 or 12.1.0.0 through 12.1.1.210.0.8.13 and 12.1.1.3IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3 · 10.0.8.13
Upgrade to API Connect 12.1.1.3 (12.1.x) or 10.0.8.13 (10.0.8.x); IBM Fix Central.