---
id: "CVE-2026-17404"
page: "https://infrastack.ai/live/CVE-2026-17404"
kind: "vulnerability"
aliases: ["CVE-2026-17404"]
title: "IBM API Connect: authenticated attacker can obtain sensitive data via request forgery"
severity: "high"
cvss: 8.5
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "api-connect", "fixed": ["10.0.8.13", "12.1.1.3"], "affected": ">= 10.0.8.0, <= 10.0.8.12; >= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["ibm-api-connect", "infrastructure", "self-hosted"]
not_affected_if: ["fixed-version-installed", "version-outside-range"]
published_at: "2026-11-07T05:18:56+00:00"
first_seen_at: "2026-11-07T05:46:07+00:00"
updated_at: "2026-11-07T06:05:45+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17404", "first_seen_at": "2026-11-07T05:46:07+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/node/7295635", "first_seen_at": "2026-11-07T06:05:45+00:00", "cites": ["https://www.ibm.com/support/pages/node/7295635", "https://www.ibm.com/support/pages/node/7295637", "https://app.opencve.io/cve/CVE-2026-17404"]}]
exploit_sources: []
---

# IBM API Connect: authenticated attacker can obtain sensitive data via request forgery

Link for people: https://infrastack.ai/live/CVE-2026-17404 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 have a server-side request forgery flaw. A remote attacker with a valid account can make the server fetch internal resources and leak sensitive information.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:api-connect affected >= 10.0.8.0, <= 10.0.8.12; >= 12.1.0.0, <= 12.1.1.2 fixed 10.0.8.13, 12.1.1.3

## How to check

Find your API Connect version (e.g. apic version, or the version shown in the API Manager/Cloud Manager). Exposed if it is 10.0.8.0 through 10.0.8.12 or 12.1.0.0 through 12.1.1.2. Fixed in 10.0.8.13 and 12.1.1.3.

## Fix

Upgrade to API Connect 12.1.1.3 (12.1.x) or 10.0.8.13 (10.0.8.x); IBM Fix Central.

## Timeline

- 2026-11-07T05:46:07+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17404
- 2026-11-07T06:05:45+00:00 analyst https://www.ibm.com/support/pages/node/7295635 — IBM bulletins nodes 7295635 (12.1.1.3) and 7295637 (10.0.8.13), listed as references on the CVE record with IBM's fix text. Fetched bulletin text was truncated before this CVE's entry, so I did not mark fields verified. Affected feature not stated by IBM. No exploitation or PoC found.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/node/7295635
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/node/7295637
- [mentions] OpenCVE CVE-2026-17404 (carries IBM's solution text) https://app.opencve.io/cve/CVE-2026-17404

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
