API-CONNECT · CVE-2026-19128 · Infrastructure
FIX → 12.1.1.3
IBM API Connect versions 12.1.0.0 through 12.1.1.2 have a server-side request forgery flaw. An authenticated attacker can make the server send requests to internal network resources, which can be used to map the network or support further attacks.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running IBM API Connect 12.1.0.0 through 12.1.1.2, which IBM ships as software you run yourself (OVA/containers). The server can be made to send requests from the system to internal network resources, which lets an attacker map the network or prepare further attacks. IBM's text says an authenticated attacker, but its CVSS vector says no login is needed, so treat reachable installs as exposed. Anyone on 12.1.1.3 or later can skip it.
Not affected if versions-outside-range
Who cares api-gateway, ibm-api-connect, self-hosted, ssrf
12.1.0.0 through 12.1.1.212.1.1.310.0.8.x line is not listed in this CVE's rangeIBM API Connect 12.1.0.0 through 12.1.1.2 could allow an authenticated attacker to send unauthorized requests from the system due to server-side request forgery. This could be used to enumerate network resources or to support further attacks.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205).