API-CONNECT · CVE-2026-17397 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A remote attacker with a valid account can make the server send requests it should not, and read sensitive information in return.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. An attacker needs a valid account, then can make the server send requests and read sensitive information in the response. IBM states no settings that change exposure; instances already on 10.0.8.13 or 12.1.1.3 or later can skip it.
Not affected if unaffected-version
Who cares authenticated, ibm-api-connect, self-hosted, ssrf
10.0.8.0 through 10.0.8.12, and 12.1.0.0 through (IBM lists the V12 OnPrem product)IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.210.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
12.1.1.3 (IBM Fix Central: https://www.ibm.com/support/pages/node/7290205); upgrade 10.0.8.x to 10.0.8.13