API-CONNECT · CVE-2026-17342 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 let a remote attacker with valid credentials execute arbitrary code, because the product improperly controls how code is generated. An attacker who can log in gets code execution on the server running the product.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-hosted/on-prem IBM API Connect deployments on 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. An attacker needs valid credentials (a low-privilege account is enough per the CVSS vector), then can run code on the server through user input that influences generated code. Teams not running API Connect can skip it.
Not affected if unaffected-version
Who cares api-connect, authenticated, ibm, self-hosted
10.0.8.0 through 10.0.8.12, or V12 on-prem 12.1.0.0 through IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code due to improper control of generation of code.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.2Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (V10) or 12.1.1.3 (V12 OnPrem), via IBM Fix Central