API-CONNECT · CVE-2026-17382 · Vendor
FIX → 10.0.8.13 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a path traversal flaw. A logged-in remote attacker can use it to obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-managed IBM API Connect deployments on 10.0.8.0 through 10.0.8.12 are affected. An attacker needs a valid login, then can use a path traversal to read sensitive information. Teams not running API Connect, or running 10.0.8.13 or later, can skip it. 12.1.x is listed in the CVE record but not in IBM's bulletin.
Not affected if auth-required, unaffected-version
Who cares api-connect, auth-required, ibm, path-traversal, self-hosted
10.0.8.0 through 10.0.8.12 are affected; upgrade to 10.0.8.1312.1.0.0 through 12.1.1.2, but IBM's bulletin does not list 12.1.x or a fix for it, so if you run 12.1.x, ask IBM support or check IBM's 12.1 bulletinsIBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to a path traversal vulnerability.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 10.0.8.13
10.0.8.13 (IBM bulletin; download via Fix Central)