API-CONNECT · CVE-2026-17365 · Vendor
FIX → 10.0.8.13
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A remote attacker with a valid account can make the server send requests to internal targets and obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-hosted IBM API Connect 10.0.8.0 to 10.0.8.12 is affected per IBM's bulletin. The attacker needs a valid account, so exposure depends on who can log in to the instance. The CVE record also lists 12.1.0.0 to 12.1.1.2, which IBM's 10.0.8.13 bulletin does not confirm. The bulletin does not say how the SSRF is triggered.
Not affected if unaffected-version
Who cares ibm-api-connect, self-hosted
10.0.8.0 to 10.0.8.12 (fixed in 10.0.8.13)12.1.0.0 to 12.1.1.2, but IBM's bulletin names only the 10.0.8 streamIBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 10.0.8.13
API Connect 10.0.8.x: upgrade to 10.0.8.13 (IBM bulletin node/7295637). 12.1.x: the CVE record (via OpenCVE) says upgrade to v12.1.1.3, but the v12.1.1.3 bulletin I read does not list this CVE; confirm with IBM before relying on it.