---
id: "CVE-2026-17397"
page: "https://infrastack.ai/live/CVE-2026-17397"
kind: "vulnerability"
aliases: ["CVE-2026-17397"]
title: "IBM API Connect: server-side request forgery leaks sensitive information to authenticated users"
severity: "high"
cvss: 8.5
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "api-connect", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}, {"name": "api-connect-v12-onprem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["authenticated", "ibm-api-connect", "self-hosted", "ssrf", "vendor"]
not_affected_if: ["unaffected-version"]
published_at: "2026-11-07T05:18:55+00:00"
first_seen_at: "2026-11-07T05:46:07+00:00"
updated_at: "2026-11-07T06:06:51+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17397", "first_seen_at": "2026-11-07T05:46:07+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:06:51+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41"]}]
exploit_sources: []
---

# IBM API Connect: server-side request forgery leaks sensitive information to authenticated users

Link for people: https://infrastack.ai/live/CVE-2026-17397 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A remote attacker with a valid account can make the server send requests it should not, and read sensitive information in return.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:api-connect affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13
- vendor:api-connect-v12-onprem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect version. Affected: 10.0.8.0 through 10.0.8.12, and 12.1.0.0 through 12.1.1.2 (IBM lists the V12 OnPrem product). Fixed in 10.0.8.13 and 12.1.1.3.

## Fix

Upgrade API Connect 12.1.x to 12.1.1.3 (IBM Fix Central: https://www.ibm.com/support/pages/node/7290205); upgrade 10.0.8.x to 10.0.8.13. IBM lists no workarounds.

## Timeline

- 2026-11-07T05:46:07+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17397
- 2026-11-07T06:06:51+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — Found in two IBM bulletins (v12.1.1.3 and 10.0.8.13); both list CVE-2026-17397, workarounds None. No config condition stated; no exploitation or PoC seen.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
