---
id: "CVE-2026-17382"
page: "https://infrastack.ai/live/CVE-2026-17382"
kind: "vulnerability"
aliases: ["CVE-2026-17382"]
title: "IBM API Connect: path traversal lets authenticated users read sensitive files"
severity: "high"
cvss: 8.5
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "api-connect", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-connect", "auth-required", "ibm", "path-traversal", "self-hosted", "vendor"]
not_affected_if: ["auth-required", "unaffected-version"]
published_at: "2026-11-07T05:18:52+00:00"
first_seen_at: "2026-11-07T05:46:06+00:00"
updated_at: "2026-11-07T06:08:53+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17382", "first_seen_at": "2026-11-07T05:46:06+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41", "first_seen_at": "2026-11-07T06:08:53+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41"]}]
exploit_sources: []
---

# IBM API Connect: path traversal lets authenticated users read sensitive files

Link for people: https://infrastack.ai/live/CVE-2026-17382 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a path traversal flaw. A logged-in remote attacker can use it to obtain sensitive information.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:api-connect affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13

## How to check

Check your API Connect version. Per IBM's bulletin, 10.0.8.0 through 10.0.8.12 are affected; upgrade to 10.0.8.13. NVD/CVE record also lists 12.1.0.0 through 12.1.1.2, but IBM's bulletin does not list 12.1.x or a fix for it, so if you run 12.1.x, ask IBM support or check IBM's 12.1 bulletins.

## Fix

Upgrade IBM API Connect to 10.0.8.13 (IBM bulletin; download via Fix Central). IBM's bulletin names no fixed version for 12.1.x.

## Timeline

- 2026-11-07T05:46:06+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17382
- 2026-11-07T06:08:53+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41 — IBM bulletin (-41) lists CVE-2026-17382 CWE-22, CVSS 8.5, affected 10.0.8.0-10.0.8.12, fix 10.0.8.13; no workarounds listed. 12.1.0.0-12.1.1.2 appears in CVE record but not in bulletin; left 12.1 unconfirmed. No exploitation or PoC found; no social search done.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to a path traversal vulnerability.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
