IBM API CONNECT · CVE-2026-17363 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a SQL injection flaw. A remote attacker with a valid account can use it to obtain sensitive information from the database.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or V12 OnPrem 12.1.0.0-12.1.1.2. Any user with a valid account (remote, low privilege) could use the SQL injection to read sensitive data from the back-end database. IBM's bulletins name no required setting and no workaround. Teams on versions 10.0.8.13 / 12.1.1.3 or later can skip it.
Not affected if version-outside-range
Who cares api-gateway, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12, and V12 OnPrem 12.1.0.0 through IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to SQL injection.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.210.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
Upgrade to API Connect 10.0.8.13 (10.0.8 line) or v12.1.1.3 (12.1 line), via IBM Fix Central.