IBM API CONNECT · CVE-2026-17388 · Vendor
FIX → 12.1.1.3 · 10.0.8.13 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 fail to check object-level access rights. A remote attacker with a valid account can obtain sensitive information belonging to other objects.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams that run IBM API Connect themselves on 10.0.8.0 to 10.0.8.12 or 12.1.0.0 to 12.1.1.2. Any logged-in user could read sensitive data belonging to other objects because object-level access is not checked (CWE-639). Needs a valid account, no user interaction. Versions 10.0.8.13 / 12.1.1.3 and later can skip it.
Not affected if fixed-version, version-outside-range
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12 or 12.1.0.0 through 12.1.1.2 (self-hosted/on-prem)10.0.8.13 and 12.1.1.3IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to broken object-level authorization.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3 · 10.0.8.13
10.0.8.x to 10.0.8.13; upgrade 12.1.x to 12.1.1.3 (IBM Fix Central)