IBM API CONNECT · CVE-2026-17399 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not sufficiently check uploaded content before processing it. A remote attacker with a valid account can make code run on the server.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-hosted IBM API Connect (V10.0.8.0-10.0.8.12 and V12 OnPrem 12.1.0.0-12.1.1.2) is exposed to anyone who holds a valid account (CVSS 9.9, CWE-434 unrestricted upload): content they upload is not sufficiently checked before processing, so code can run on the server. IBM does not name the upload feature. Teams not running these versions can skip it; IBM does not rule out other deployment types in the bulletin.
Not affected if auth-required, unaffected-version
Who cares api-gateway, auth-required, ibm-api-connect, self-hosted
10.0.8.12, and V12 OnPrem v12.1.0.0 through IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code due to insufficient validation of uploaded content. Content uploaded to the product is not sufficiently checked before it is processed, which could allow code to run on the server.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
v12.1.1.210.0.8.13 and v12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13, or V12 OnPrem to v12.1.1.3 (Fix Central; V12 link https://www.ibm.com/support/pages/node/7290205)