IBM API CONNECT · CVE-2026-17396 · Vendor
FIX → 12.1.1.3 · 10.0.8.13
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a SQL injection flaw. A remote attacker with a valid account can use it to obtain sensitive information from the backing database.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. Exploitation needs a valid (authenticated) account that can reach the product over the network; a successful attack can read sensitive data from the backing database. IBM's published text does not name the affected endpoint. Versions 10.0.8.13 and 12.1.1.3 or later can skip it.
Not affected if unaffected-version
Who cares api-gateway, ibm-api-connect, self-hosted
10.0.8.0 to 10.0.8.12 or 12.1.0.0 to 12.1.1.210.0.8.13 and 12.1.1.3IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to SQL injection.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3 · 10.0.8.13
Upgrade IBM API Connect 12.1.x to v12.1.1.3, or 10.0.8.x to 10.0.8.13 (IBM bulletins; download via IBM Fix Central).