IBM API CONNECT V12 ONPREM · CVE-2026-18838 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect V12 OnPrem v12.1.0.0 to v12.1.1.2 does not sufficiently verify identity information supplied in requests (CWE-290). IBM rates it CVSS 9.4 with no privileges required: a remote attacker can impersonate another user, read sensitive information and modify API configurations. Fixed in v12.1.1.3; IBM lists no workarounds.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 are affected. IBM's CVSS vector shows it is reachable over the network with no credentials or user interaction. Teams on v12.1.1.3 or later can skip it; the bulletin lists no other API Connect versions or hosted offerings for this CVE.
Not affected if other-versions, v12.1.1.3-or-later
Who cares api-gateway, ibm-api-connect, on-prem, self-hosted
v12.1.0.0 through v12.1.1.2 is affected; v12.1.1.3 or later is fixed10.0.8.x line is not listed for this CVE in this bulletin; also check other API Connect lines against their own IBM bulletinsIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information and modify API configurations due to improper authentication. Identity information supplied in requests is not sufficiently verified, which could allow a caller to impersonate another user.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)