IBM API CONNECT · CVE-2026-17357 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A logged-in attacker can make the server send requests to internal network services that the attacker cannot reach directly.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or V12 OnPrem 12.1.0.0-12.1.1.2. A logged-in user (IBM's CVSS vector requires high privileges) can make the server send requests to internal network services and read the result. IBM names no required setting and no workaround. Versions 10.0.8.13 / 12.1.1.3 or later can skip it.
Not affected if no-authenticated-users, unaffected-version, version-outside-range
Who cares api-gateway, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12, and V12 OnPrem 12.1.0.0 through IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to access internal network services due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.210.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8 line) or v12.1.1.3 (V12 OnPrem), via IBM Fix Central