API-CONNECT · CVE-2026-17298 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A remote attacker with an account can make the server issue requests to internal destinations and read sensitive information in return.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running IBM API Connect 10.0.8.0 to 10.0.8.12 or v12.1.0.0 to v12.1.1.2 (IBM lists the 12.1 row as On-Prem). An attacker needs a valid low-privilege account; they can then make the server request internal destinations and read the response. IBM does not say which feature or endpoint is involved. Teams on 10.0.8.13 / v12.1.1.3 or later, or without API Connect, can skip it.
Not affected if auth-required, unaffected-version
Who cares api-connect, auth-required, ibm, self-hosted
10.0.8.0 to 10.0.8.12 and v12.1.0.0 to v12.1.1.2 (IBM lists the 12.1 row as )IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
API Connect V12 OnPrem10.0.8.13 and v12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
Upgrade to 10.0.8.13 (10.0.8.x line) or v12.1.1.3 (v12.1.x line); IBM lists no workarounds or mitigations.