---
id: "CVE-2026-17298"
page: "https://infrastack.ai/live/CVE-2026-17298"
kind: "vulnerability"
aliases: ["CVE-2026-17298"]
title: "IBM API Connect: authenticated SSRF leaks sensitive information to remote attackers"
severity: "critical"
cvss: 9.9
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "api-connect", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}, {"name": "api-connect-v12-onprem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-connect", "auth-required", "ibm", "self-hosted", "vendor"]
not_affected_if: ["auth-required", "unaffected-version"]
published_at: "2026-11-07T05:18:37+00:00"
first_seen_at: "2026-11-07T05:46:02+00:00"
updated_at: "2026-11-07T05:56:21+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17298", "first_seen_at": "2026-11-07T05:46:02+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T05:56:21+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41"]}]
exploit_sources: []
---

# IBM API Connect: authenticated SSRF leaks sensitive information to remote attackers

Link for people: https://infrastack.ai/live/CVE-2026-17298 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A remote attacker with an account can make the server issue requests to internal destinations and read sensitive information in return.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:api-connect affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13
- vendor:api-connect-v12-onprem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your installed API Connect version. Affected: 10.0.8.0 to 10.0.8.12 and v12.1.0.0 to v12.1.1.2 (IBM lists the 12.1 row as 'API Connect V12 OnPrem'). Fixed: 10.0.8.13 and v12.1.1.3.

## Fix

Upgrade to 10.0.8.13 (10.0.8.x line) or v12.1.1.3 (v12.1.x line); IBM lists no workarounds or mitigations.

## Timeline

- 2026-11-07T05:46:02+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17298
- 2026-11-07T05:56:21+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — Read IBM bulletins (-41 for 10.0.8.x, -39 for 12.1.x): CVE listed, fix 10.0.8.13 / v12.1.1.3, no workarounds. IBM gives no feature/endpoint detail. Not exploited, no PoC seen.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
