API-CONNECT · CVE-2026-17285 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not restrict external references when validating schemas. A remote authenticated attacker can make the server retrieve content it should not access and obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect 10.0.8.0 to 10.0.8.12 or V12 OnPrem 12.1.0.0 to 12.1.1.2. An attacker needs a valid login, then can make the server fetch external resources while validating schemas and read content it should not reach. Installations on 10.0.8.13 or v12.1.1.3 and later can skip it.
Not affected if version-outside-range
Who cares api-gateway, ibm-api-connect, self-hosted, ssrf
10.0.8.0 through 10.0.8.12, and 12.1.0.0 through 12.1.1.2 (IBM lists V12 OnPrem)10.0.8.13 and IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper validation of external references. When schemas are validated, references to external resources are not sufficiently restricted, which could allow the server to retrieve content it should not access.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
v12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8 line) or v12.1.1.3 (12.1 line)