---
id: "CVE-2026-17285"
page: "https://infrastack.ai/live/CVE-2026-17285"
kind: "vulnerability"
aliases: ["CVE-2026-17285"]
title: "IBM API Connect: server-side request forgery via external schema references lets authenticated users read data"
severity: "high"
cvss: 7.7
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "api-connect", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}, {"name": "api-connect-v12-onprem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "ibm-api-connect", "self-hosted", "ssrf", "vendor"]
not_affected_if: ["version-outside-range"]
published_at: "2026-11-07T05:18:34+00:00"
first_seen_at: "2026-11-07T05:46:01+00:00"
updated_at: "2026-11-07T06:22:03+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17285", "first_seen_at": "2026-11-07T05:46:01+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/node/7295637", "first_seen_at": "2026-11-07T06:22:03+00:00", "cites": ["https://www.ibm.com/support/pages/node/7295637", "https://www.ibm.com/support/pages/node/7295635"]}]
exploit_sources: []
---

# IBM API Connect: server-side request forgery via external schema references lets authenticated users read data

Link for people: https://infrastack.ai/live/CVE-2026-17285 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not restrict external references when validating schemas. A remote authenticated attacker can make the server retrieve content it should not access and obtain sensitive information.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:api-connect affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13
- vendor:api-connect-v12-onprem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect version. Affected: 10.0.8.0 through 10.0.8.12, and 12.1.0.0 through 12.1.1.2 (IBM lists V12 OnPrem). Fixed: 10.0.8.13 and v12.1.1.3.

## Fix

Upgrade to 10.0.8.13 (10.0.8 line) or v12.1.1.3 (12.1 line). IBM says no workarounds or mitigations.

## Timeline

- 2026-11-07T05:46:01+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17285
- 2026-11-07T06:22:03+00:00 analyst https://www.ibm.com/support/pages/node/7295637 — Read both IBM bulletins (node/7295637 for 10.0.8.x, node/7295635 for 12.1.x): fixed in 10.0.8.13 and v12.1.1.3, workarounds 'None'. Bulletin 7295635 lists V12 OnPrem; not stated whether other V12 deployment types are affected. No exploitation or PoC checked beyond bulletins.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/node/7295637
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/node/7295635

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper validation of external references. When schemas are validated, references to external resources are not sufficiently restricted, which could allow the server to retrieve content it should not access.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
