API-CONNECT · CVE-2026-17146 · Vendor
FIX → 10.0.8.13
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 fail to validate input properly. A remote attacker with a valid account can execute arbitrary JavaScript and obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams that run self-managed IBM API Connect 10.0.8.0 to 10.0.8.12 or 12.1.0.0 to 12.1.1.2. IBM classes it as cross-site scripting (CWE-79) reachable by a remote user with a valid account, no user interaction (CVSS 9.9, scope changed). Teams on 10.0.8.13 or later can skip it.
Not affected if version-outside-range
Who cares api-gateway, auth-required, ibm-api-connect, self-hosted, xss
10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.210.0.8.x: IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary JavaScript and obtain sensitive information due to improper input validation.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
10.0.8.13Upgrade to 10.0.8.13
10.0.8.13 for the 10.0.8.x branch (IBM bulletin)v12.1.1.3 bulletin is the likely fix, but this CVE was not seen in the portion read; confirm on the bulletin