---
id: "CVE-2026-17146"
page: "https://infrastack.ai/live/CVE-2026-17146"
kind: "vulnerability"
aliases: ["CVE-2026-17146"]
title: "IBM API Connect: authenticated users can run JavaScript (cross-site scripting) and read sensitive data (fixed in 10.0.8.13)"
severity: "critical"
cvss: 9.9
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "api-connect", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}, {"name": "api-connect-v12-onprem", "fixed": [], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "auth-required", "ibm-api-connect", "self-hosted", "vendor", "xss"]
not_affected_if: ["version-outside-range"]
published_at: "2026-11-07T05:18:27+00:00"
first_seen_at: "2026-11-07T05:45:59+00:00"
updated_at: "2026-11-07T05:59:08+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17146", "first_seen_at": "2026-11-07T05:45:59+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41", "first_seen_at": "2026-11-07T05:59:08+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41", "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect: authenticated users can run JavaScript (cross-site scripting) and read sensitive data (fixed in 10.0.8.13)

Link for people: https://infrastack.ai/live/CVE-2026-17146 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 fail to validate input properly. A remote attacker with a valid account can execute arbitrary JavaScript and obtain sensitive information.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:api-connect affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13
- vendor:api-connect-v12-onprem affected >= 12.1.0.0, <= 12.1.1.2 fixed no fixed version listed

## How to check

Check your API Connect version. Affected per NVD: 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2. Fixed on 10.0.8.x: 10.0.8.13.

## Fix

10.0.8.13 for the 10.0.8.x branch (IBM bulletin). For 12.1.x, IBM's v12.1.1.3 bulletin is the likely fix, but this CVE was not seen in the portion read; confirm on the bulletin.

## Timeline

- 2026-11-07T05:45:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17146
- 2026-11-07T05:59:08+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41 — IBM bulletin -41 (10.0.8.13) lists CVE-2026-17146 (CWE-79, CVSS 9.9, authenticated, no UI). 12.1.x bulletin -39 (v12.1.1.3) read but page truncated before this CVE, so 12.1 fix not confirmed for this CVE; sibling CVEs use 12.1.1.3. No exploitation/PoC found.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41
- [mentions] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary JavaScript and obtain sensitive information due to improper input validation.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
