API-CONNECT-V12-ONPREM · CVE-2026-16920 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM says API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 could let a remote authenticated attacker bypass security restrictions due to a confused deputy flaw (CWE-441, unintended proxy or intermediary). IBM rated it CVSS 9.9 with changed scope. IBM does not say which restrictions are bypassed.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect V12 OnPrem v12.1.0.0 to v12.1.1.2. Any authenticated user may be able to bypass security restrictions through a confused deputy flaw (CVSS 9.9, changed scope); IBM does not say which restrictions. Teams on v12.1.1.3 or later, and those not running V12 OnPrem, can skip it.
Not affected if outside-affected-versions, unaffected-version, version-outside-range
Who cares api-gateway, auth-required, ibm-api-connect, self-hosted
v12.1.0.0 - v12.1.1.2v12.1.1.310.0.8.x, IBM does not list it hereIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions due to a confused deputy vulnerability.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 via IBM Fix Central (https://www.ibm.com/support/pages/node/7290205)