---
id: "CVE-2026-16920"
page: "https://infrastack.ai/live/CVE-2026-16920"
kind: "vulnerability"
aliases: ["CVE-2026-16920"]
title: "IBM API Connect V12 OnPrem: logged-in user can bypass security restrictions via confused deputy flaw (fixed in 12.1.1.3)"
severity: "critical"
cvss: 9.9
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "api-connect-v12-onprem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "auth-required", "ibm-api-connect", "infrastructure", "self-hosted"]
not_affected_if: ["outside-affected-versions", "unaffected-version", "version-outside-range"]
published_at: "2026-11-07T05:18:22+00:00"
first_seen_at: "2026-11-07T05:45:58+00:00"
updated_at: "2026-11-07T06:01:26+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-16920", "first_seen_at": "2026-11-07T05:45:58+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:01:26+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect V12 OnPrem: logged-in user can bypass security restrictions via confused deputy flaw (fixed in 12.1.1.3)

Link for people: https://infrastack.ai/live/CVE-2026-16920 (this .md is for agents)

IBM says API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 could let a remote authenticated attacker bypass security restrictions due to a confused deputy flaw (CWE-441, unintended proxy or intermediary). IBM rated it CVSS 9.9 with changed scope. IBM does not say which restrictions are bypassed.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:api-connect-v12-onprem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect V12 OnPrem version. Affected per IBM: v12.1.0.0 - v12.1.1.2. Fixed: v12.1.1.3. A valid account is required. IBM's bulletin lists only V12 OnPrem for this CVE; if you run 10.0.8.x, IBM does not list it here.

## Fix

Upgrade to v12.1.1.3 via IBM Fix Central (https://www.ibm.com/support/pages/node/7290205). IBM lists no workarounds or mitigations.

## Timeline

- 2026-11-07T05:45:58+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-16920
- 2026-11-07T06:01:26+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — Read IBM bulletin -39 (v12.1.1.3): CVE-2026-16920 CWE-441, CVSS 9.9, V12 OnPrem v12.1.0.0-v12.1.1.2, fix v12.1.1.3, workarounds None. Exact restrictions bypassed not stated by IBM. No exploitation/PoC or social search done.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions due to a confused deputy vulnerability.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
