API-CONNECT · CVE-2026-17301 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not properly verify a cryptographic signature. An unauthenticated attacker can use this to bypass authentication.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect 10.0.8.0 to 10.0.8.12 or V12 OnPrem 12.1.0.0 to 12.1.1.2. An unauthenticated network attacker can bypass authentication because a cryptographic signature is not properly verified; IBM gives no further detail on which components or configurations are reached, so treat any reachable instance as exposed. Versions at 10.0.8.13 or 12.1.1.3 and later can skip it.
Not affected if versions-outside-affected-ranges
Who cares api-gateway, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12, and 12.1.0.0 through (V12 OnPrem)IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow an unauthenticated attacker to bypass authentication due to improper verification of a cryptographic signature.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.210.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.x to 10.0.8.13, or 12.1.x to 12.1.1.3