IBM API CONNECT V12 ONPREM · CVE-2026-17361 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A remote attacker who holds valid credentials can make the server send requests on their behalf and read back sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect V12 OnPrem 12.1.0.0 through 12.1.1.2. An attacker needs a valid account; they can make the server send requests and read back sensitive information. IBM's bulletin does not name the endpoint. Other versions and managed offerings are not listed as affected in this bulletin.
Not affected if version-outside-12.1.0.0-to-12.1.1.2
Who cares authenticated, ibm-api-connect, self-hosted, ssrf
v12.1.0.0 through v12.1.1.2 are affectedv12.1.1.3 or laterIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade to IBM API Connect v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)