---
id: "CVE-2026-18838"
page: "https://infrastack.ai/live/CVE-2026-18838"
kind: "vulnerability"
aliases: ["CVE-2026-18838"]
title: "IBM API Connect 12.1: unauthenticated remote caller can impersonate users and change API configurations"
severity: "critical"
cvss: 9.4
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "IBM API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "ibm-api-connect", "on-prem", "self-hosted", "vendor"]
not_affected_if: ["other-versions", "v12.1.1.3-or-later"]
published_at: "2026-11-07T05:18:59+00:00"
first_seen_at: "2026-11-07T05:46:08+00:00"
updated_at: "2026-11-07T05:49:58+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-18838", "first_seen_at": "2026-11-07T05:46:08+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T05:49:58+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect 12.1: unauthenticated remote caller can impersonate users and change API configurations

Link for people: https://infrastack.ai/live/CVE-2026-18838 (this .md is for agents)

IBM API Connect V12 OnPrem v12.1.0.0 to v12.1.1.2 does not sufficiently verify identity information supplied in requests (CWE-290). IBM rates it CVSS 9.4 with no privileges required: a remote attacker can impersonate another user, read sensitive information and modify API configurations. Fixed in v12.1.1.3; IBM lists no workarounds.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:IBM API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect V12 OnPrem version. v12.1.0.0 through v12.1.1.2 is affected; v12.1.1.3 or later is fixed. The 10.0.8.x line is not listed for this CVE in this bulletin; also check other API Connect lines against their own IBM bulletins.

## Fix

Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205). IBM lists no workarounds or mitigations.

## Timeline

- 2026-11-07T05:46:08+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-18838
- 2026-11-07T05:49:58+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — Read IBM bulletin (-39): CVE-2026-18838 CWE-290, CVSS 9.4 AV:N/PR:N (no credentials), affects API Connect V12 OnPrem v12.1.0.0-v12.1.1.2, fix v12.1.1.3, workarounds: None. No exploitation or PoC seen.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information and modify API configurations due to improper authentication. Identity information supplied in requests is not sufficiently verified, which could allow a caller to impersonate another user.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
