IBM API CONNECT · CVE-2026-17381 · Vendor
FIX → 12.1.1.3 · 10.0.8.13 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 fail to validate authorization properly when user-controlled keys are used. A remote attacker with a valid account can obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams that run IBM API Connect themselves on 10.0.8.0 to 10.0.8.12 or 12.1.0.0 to 12.1.1.2. Any logged-in user could read sensitive data they should not see, because authorization is checked against user-controlled keys (CWE-639). Needs a valid account, no user interaction. IBM does not say which endpoints are involved. Versions 10.0.8.13 / 12.1.1.3 and later can skip it.
Not affected if fixed-version, version-outside-range
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12 or 12.1.0.0 through (self-hosted/on-prem)IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper authorization validation using user-controlled keys.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.210.0.8.13 and 12.1.1.3Upgrade to 12.1.1.3 · 10.0.8.13
10.0.8.x to 10.0.8.13; upgrade 12.1.x (V12 OnPrem) to 12.1.1.3 (IBM Fix Central)