IBM API CONNECT · CVE-2026-17326 · Infrastructure
FIX → 12.1.1.3 · 10.0.8.13 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 have improper authentication that lets a logged-in remote user bypass security restrictions. The sources do not say what restrictions are bypassed or what the attacker gains beyond that.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. An attacker needs a valid login on the instance (low privileges, network access). IBM says only that security restrictions can be bypassed; it gives no detail on which ones. Teams not running API Connect, or already on 12.1.1.3 or later, can skip it.
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.212.1.1.3 (12.1 line)IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions due to improper authentication.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3 · 10.0.8.13
v12.1.1.3 (IBM bulletin)10.0.8.x, the CVE record says upgrade to 10.0.8.13; not confirmed on an IBM page