---
id: "CVE-2026-17326"
page: "https://infrastack.ai/live/CVE-2026-17326"
kind: "vulnerability"
aliases: ["CVE-2026-17326"]
title: "IBM API Connect: authenticated remote attacker can bypass security restrictions"
severity: "high"
cvss: 8.1
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "IBM API Connect", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}, {"name": "IBM API Connect 10.0.8", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "authenticated", "ibm-api-connect", "infrastructure", "self-hosted"]
not_affected_if: []
published_at: "2026-11-07T05:18:42+00:00"
first_seen_at: "2026-11-07T05:46:03+00:00"
updated_at: "2026-11-07T06:17:27+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17326", "first_seen_at": "2026-11-07T05:46:03+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:17:27+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "https://www.ibm.com/support/pages/node/7290205"]}]
exploit_sources: []
---

# IBM API Connect: authenticated remote attacker can bypass security restrictions

Link for people: https://infrastack.ai/live/CVE-2026-17326 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 have improper authentication that lets a logged-in remote user bypass security restrictions. The sources do not say what restrictions are bypassed or what the attacker gains beyond that.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:IBM API Connect affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3
- vendor:IBM API Connect 10.0.8 affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13

## How to check

Check your API Connect version (management/gateway/portal). Affected: 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2. Fixed in 12.1.1.3 (12.1 line).

## Fix

Upgrade 12.1.x to v12.1.1.3 (IBM bulletin). For 10.0.8.x, the CVE record says upgrade to 10.0.8.13; not confirmed on an IBM page.

## Timeline

- 2026-11-07T05:46:03+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17326
- 2026-11-07T06:17:27+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — IBM bulletin (-39) lists CVE-2026-17326 (CWE-287, CVSS 8.1, C:H/I:H) as fixed in v12.1.1.3. IBM gives no detail on which restrictions are bypassed. 10.0.8.13 fix for the 10.0.8 line comes only from the CVE record's solution text (OpenCVE copy), not read on an IBM page, so only the 12.1 fix is verified. No exploitation or PoC seen.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39
- [fix] IBM API Connect v12.1.1.3 is now available https://www.ibm.com/support/pages/node/7290205

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions due to improper authentication.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
