IBM API CONNECT · CVE-2026-17324 · Vendor
FIX → 12.1.1.3
IBM API Connect versions 12.1.0.0 through 12.1.1.2 lack authentication on a critical function. A remote attacker can read sensitive configuration data and perform unauthorized actions.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-hosted IBM API Connect 12.1.0.0 through 12.1.1.2 whose management or gateway endpoints can be reached by an unauthenticated remote attacker (CVSS 8.3, no privileges required). IBM says the flaw is missing authentication on a critical function. It does not name the endpoint. Teams on IBM API Connect 10.0.8.x are not listed for this CVE. Installs already on 12.1.1.3 can skip it.
Not affected if unknown
Who cares api-gateway, auth-bypass, ibm-api-connect, self-hosted
12.1.0.0 through 12.1.1.2 are affected; v12.1.1.3 is the fixed releaseUpgrade to 12.1.1.3
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to access sensitive configuration data and perform unauthorized actions due to missing authentication for a critical function.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade IBM API Connect to v12.1.1.3 (Fix Central; release page https://www.ibm.com/support/pages/node/7290205)