IBM API CONNECT · CVE-2026-17309 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 do not properly validate certificates. A remote attacker may be able to obtain sensitive information and change configuration.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-managed (on-prem) IBM API Connect V12 deployments running v12.1.0.0 through v12.1.1.2. IBM rates it CVSS 8.0 with an adjacent-network, high-complexity, no-privileges vector, so it matters most where an attacker can reach the network segment API Connect uses. IBM's bulletin lists only API Connect V12 OnPrem as affected, so V10 and other deployment types can skip it.
Not affected if managed-hosting, v10-release
Who cares api-gateway, ibm-api-connect, self-hosted
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fixIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information and tamper with configuration due to improper certificate validation.
This page as .md · .json · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect V12 to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)