---
id: "CVE-2026-17309"
page: "https://infrastack.ai/live/CVE-2026-17309"
kind: "vulnerability"
aliases: ["CVE-2026-17309"]
title: "IBM API Connect: improper certificate validation exposes data and config tampering"
severity: "high"
cvss: 8.0
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "IBM API Connect", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "ibm-api-connect", "self-hosted", "vendor"]
not_affected_if: ["managed-hosting", "v10-release"]
published_at: "2026-11-07T05:18:39+00:00"
first_seen_at: "2026-11-07T05:46:02+00:00"
updated_at: "2026-11-07T06:19:49+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17309", "first_seen_at": "2026-11-07T05:46:02+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:19:49+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect: improper certificate validation exposes data and config tampering

Link for people: https://infrastack.ai/live/CVE-2026-17309 (this .md is for agents)

IBM API Connect versions 12.1.0.0 through 12.1.1.2 do not properly validate certificates. A remote attacker may be able to obtain sensitive information and change configuration.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:IBM API Connect affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your IBM API Connect V12 on-prem version. Versions v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fix.

## Fix

Upgrade IBM API Connect V12 to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)

## Timeline

- 2026-11-07T05:46:02+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17309
- 2026-11-07T06:19:49+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — IBM bulletin (api-connect-39, 2026-11-05) lists CVE-2026-17309: improper cert validation, CVSS 8.0 AV:A/AC:H/PR:N, affected V12 OnPrem 12.1.0.0-12.1.1.2, fixed 12.1.1.3, workarounds: None. Bulletin gives no further trigger details; exploitation not reported.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information and tamper with configuration due to improper certificate validation.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
