API-CONNECT · CVE-2026-17280 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not restrict repeated authentication attempts. A remote attacker without an account can guess passwords until they obtain valid credentials.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0 to 10.0.8.12 or V12 OnPrem 12.1.0.0 to 12.1.1.2 whose login endpoints can be reached over the network. An attacker needs no account but IBM rates attack complexity high. IBM lists no workaround. Anyone already on 10.0.8.13 or v12.1.1.3 can skip it.
Who cares api-gateway, ibm-api-connect, self-hosted
10.0.8.0 to 10.0.8.12, or V12 OnPrem 12.1.0.0 to 12.1.1.2IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to perform unauthenticated brute-force attacks to obtain valid credentials due to improper restriction of excessive authentication attempts.
This page as .md · .json · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
10.0.8.13 and v12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.x to 10.0.8.13; upgrade API Connect V12 OnPrem 12.1.x to v12.1.1.3