API CONNECT · CVE-2026-17190 · Infrastructure
FIX → 12.1.1.3 · 10.0.8.13 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not sanitize HTML supplied by a provider before displaying it. An authenticated attacker can get script to run in another user's browser.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams that run IBM API Connect in the affected version ranges and let providers supply HTML that other users view in the portal or console. The sources do not say which provider-facing features render that HTML, so the exposure path is unknown. Installations outside the listed ranges are not affected.
Not affected if outside-affected-versions
Who cares api-gateway, ibm-api-connect
10.0.8.0 through 10.0.8.12, and 12.1.0.0 through 12.1.1.210.0.8.13 and 12.1.1.3IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary JavaScript due to cross-site scripting. HTML content supplied by a provider is not sufficiently sanitized before it is displayed, which could allow script content to run in the user's browser.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3 · 10.0.8.13
10.0.8.13 (10.0.8 line) or 12.1.1.3 (12.1 line) via IBM Fix Central