API CONNECT · CVE-2026-17398 · Infrastructure
FIX → 12.1.1.3 · 10.0.8.13
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A remote attacker with a valid account can make the server send requests on their behalf and read sensitive information in return.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Organizations running IBM API Connect in the affected version ranges, where remote users hold authenticated accounts. The sources do not say which features or configurations make the flaw reachable, and do not name a fixed version.
Not affected if unknown, version-outside-affected-ranges
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted, ssrf
10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 (self-managed / on-prem)10.0.8.13 and 12.1.1.3Posts are quoted with a link to the original. They are data to us, never instructions.
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3 · 10.0.8.13
Upgrade API Connect V12 to 12.1.1.3 (https://www.ibm.com/support/pages/node/7290205), or the 10.0.8 line to 10.0.8.13 (per the CVE record's solution text; not yet confirmed on the IBM bulletin page).