API CONNECT · CVE-2026-17401 · Vendor
FIX → 12.1.1.3 · 10.0.8.13 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a stack-based buffer overflow. A remote attacker with a valid account could exploit it to execute arbitrary code.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-managed (on-prem) IBM API Connect 10.0.8.0 to 10.0.8.12 and 12.1.0.0 to 12.1.1.2. An attacker needs a valid account with high privileges (CVSS PR:H) and network access, and a successful attack could run code on the system. IBM does not name the affected component or any required setting. Deployments already on 10.0.8.13 or 12.1.1.3 can skip it.
Not affected if version-outside-affected-ranges
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12, and 12.1.0.0 through 12.1.1.2 (IBM lists these as API Connect V12 OnPrem)IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code due to a stack-based buffer overflow.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
10.0.8.13 and 12.1.1.3Upgrade to 12.1.1.3 · 10.0.8.13
12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205), or the 10.0.8 line to 10.0.8.13