API CONNECT · CVE-2026-17403 · Infrastructure
FIX → 12.1.1.3 · 10.0.8.13
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 ship with hard-coded credentials. A remote attacker who uses them gets full administrative control of the product.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams that run IBM API Connect themselves (on-premises, containers/Kubernetes or VMware OVA) at 10.0.8.0 to 10.0.8.12 or 12.1.0.0 to 12.1.1.2. IBM describes it as a remote attacker gaining full administrative control through hard-coded credentials; the CVSS vector gives no authentication or user interaction required but high attack complexity. IBM's text does not say whether default deployments are reachable, so assume yes. Teams already on 10.0.8.13 or 12.1.1.3 or later can skip it.
Not affected if unsupported-version-range
Who cares api-gateway, hard-coded-credentials, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.210.0.8.13 and IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to gain full administrative control due to the use of hard-coded credentials.
This page as .md · .json · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.3Upgrade to 12.1.1.3 · 10.0.8.13
Upgrade to IBM API Connect 12.1.1.3 (12.1.x line) or 10.0.8.13 (10.0.8.x line).