API CONNECT · CVE-2026-17402 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not neutralize user input passed to the operating system. A remote attacker with a valid account can run arbitrary commands on the underlying host.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or V12 OnPrem 12.1.0.0-12.1.1.2 are exposed to any user with a valid account (low privilege), who can run OS commands on the host. IBM does not say which input or feature is vulnerable, so the version is the only check. Teams already on 10.0.8.13 or 12.1.1.3 or later can skip it.
Not affected if version-outside-range
Who cares api-gateway, auth-required, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12, or V12 OnPrem 12.1.0.0 through 12.1.1.2IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary commands due to OS command injection. User-supplied input is not properly neutralized before it is passed to the operating system, which could allow commands to run on the underlying host.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
10.0.8.1312.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8.x line) or v12.1.1.3 (V12 OnPrem)