API-CONNECT · CVE-2026-17158 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 have an improper authentication flaw. A remote attacker with a valid account can gain elevated privileges.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0 to 10.0.8.12 or V12 OnPrem 12.1.0.0 to 12.1.1.2. Any account on the platform can be used by an attacker to gain elevated privileges (improper authentication, CWE-287; CVSS 9.9 with changed scope), so exposure depends on who can hold an account. IBM does not describe the exact mechanism. Teams on 10.0.8.13 or 12.1.1.3 or later can skip it.
Not affected if unaffected-version
Who cares api-gateway, auth-required, ibm-api-connect, self-hosted
v12.1.0.0 - v12.1.1.2IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to gain elevated privileges due to improper authentication.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
10.0.8.13v12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8.x) or v12.1.1.3 (V12 OnPrem 12.1.x)