API CONNECT · CVE-2026-16716 · Vendor
FIX → 12.1.1.3 · 10.0.8.13 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not properly restrict how security tokens are assigned. A remote attacker with a valid account can bypass security restrictions to read and modify sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Organizations running IBM API Connect in the affected version ranges are exposed, and the attacker needs a valid account on the platform. Deployments outside those ranges are not affected by this description. The sources do not say which features or configurations are required.
Not affected if auth-required, version-outside-affected-ranges
Who cares api-gateway, auth-required, ibm-api-connect, self-hosted
10.0.8.0 to 10.0.8.12 or 12.1.0.0 to 12.1.1.210.0.8.13 and 12.1.1.3IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions to access and modify sensitive information due to improper restriction of security token assignment.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3 · 10.0.8.13
10.0.8.13 (IBM bulletin)12.1.1.3 (not stated in the bulletin text I read)