---
id: "CVE-2026-16716"
page: "https://infrastack.ai/live/CVE-2026-16716"
kind: "vulnerability"
aliases: ["CVE-2026-16716"]
title: "IBM API Connect: authenticated users can bypass restrictions and modify sensitive data"
severity: "high"
cvss: 8.8
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "API Connect", "fixed": ["10.0.8.13", "12.1.1.3"], "affected": "10.0.8.0 - 10.0.8.12; 12.1.0.0 - 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "auth-required", "ibm-api-connect", "self-hosted", "vendor"]
not_affected_if: ["auth-required", "version-outside-affected-ranges"]
published_at: "2026-11-07T05:18:20+00:00"
first_seen_at: "2026-11-07T05:45:57+00:00"
updated_at: "2026-11-07T06:26:14+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-16716", "first_seen_at": "2026-11-07T05:45:57+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41", "first_seen_at": "2026-11-07T06:26:14+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41", "https://app.opencve.io/cve/CVE-2026-16716"]}]
exploit_sources: []
---

# IBM API Connect: authenticated users can bypass restrictions and modify sensitive data

Link for people: https://infrastack.ai/live/CVE-2026-16716 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not properly restrict how security tokens are assigned. A remote attacker with a valid account can bypass security restrictions to read and modify sensitive information.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect affected 10.0.8.0 - 10.0.8.12; 12.1.0.0 - 12.1.1.2 fixed 10.0.8.13, 12.1.1.3

## How to check

Check your API Connect version. Exposed if it is 10.0.8.0 to 10.0.8.12 or 12.1.0.0 to 12.1.1.2. Fixed in 10.0.8.13 and 12.1.1.3. The attacker needs a valid account.

## Fix

Upgrade IBM API Connect V10.0.8 to 10.0.8.13 (IBM bulletin). For V12.1, the CVE record's vendor solution says upgrade to 12.1.1.3 (not stated in the bulletin text I read).

## Timeline

- 2026-11-07T05:45:57+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-16716
- 2026-11-07T06:26:14+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41 — IBM bulletin (api-connect-41, 2026-11-05) lists CVE-2026-16716 (CWE-1259, CVSS 8.8, AV:N/PR:L) with fix 10.0.8.13, workarounds None. Bulletin affected table covers only V10.0.8.0-12; the V12.1 range and 12.1.1.3 fix come from the CVE record (OpenCVE), not verified on IBM page. No exploitation or PoC found; social search not run (routine B).

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41
- [mentions] OpenCVE CVE-2026-16716 (CNA record with 12.1.1.3 solution) https://app.opencve.io/cve/CVE-2026-16716

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions to access and modify sensitive information due to improper restriction of security token assignment.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
