IBM API CONNECT · CVE-2026-16715 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 fail to check object ownership, so a logged-in user can read sensitive information belonging to other tenants. The attacker needs a valid account on the affected platform, and the flaw is reachable over the network.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running IBM API Connect 10.0.8.0-10.0.8.12 or v12 on-prem 12.1.0.0-12.1.1.2. Any logged-in user can read sensitive data from other tenants (broken object-level authorization), so shared multi-tenant or multi-organization installs are most exposed. Single-tenant installs where every account is trusted have lower risk, but should still upgrade.
Not affected if no-untrusted-accounts, single-tenant, unaffected-version
Who cares api-gateway, auth-required, ibm-api-connect, multi-tenant, self-hosted
10.0.8.0 to 10.0.8.12 and 12.1.0.0 to 12.1.1.2IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information from other tenants due to broken object-level authorization.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
10.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8 line) or v12.1.1.3 (v12 line)