API CONNECT · CVE-2026-16709 · Infrastructure
FIX → 12.1.1.3 · 10.0.8.13 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not neutralize user input when a web page is updated. An authenticated attacker can get script content to run in another user's browser session.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect 10.0.8.0 through 10.0.8.12 or 12.1.0.0 through 12.1.1.2. An attacker needs a valid account, and a second user must view the page the attacker modified, so shared multi-user instances are the main concern. IBM's text does not name the page or feature. Instances already on 10.0.8.13 or 12.1.1.3 can skip it.
Not affected if auth-required, version-outside-range
Who cares api-connect, ibm, self-hosted
10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.210.0.8.13 and 12.1.1.3IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary JavaScript in the victim's browser due to cross-site scripting. User-supplied input is not properly neutralized when a web page is updated, so script content could run in another user's session.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3 · 10.0.8.13
10.0.8.x to 10.0.8.13, and 12.1.x to v12.1.1.3 (IBM bulletins)10.0.8 branch