---
id: "CVE-2026-16709"
page: "https://infrastack.ai/live/CVE-2026-16709"
kind: "vulnerability"
aliases: ["CVE-2026-16709"]
title: "IBM API Connect: stored XSS lets a logged-in user run scripts in others' browsers"
severity: "high"
cvss: 8.7
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "API Connect", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}, {"name": "API Connect", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-connect", "ibm", "infrastructure", "self-hosted"]
not_affected_if: ["auth-required", "version-outside-range"]
published_at: "2026-11-07T05:18:19+00:00"
first_seen_at: "2026-11-07T05:45:57+00:00"
updated_at: "2026-11-07T06:27:22+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-16709", "first_seen_at": "2026-11-07T05:45:57+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/node/7295637", "first_seen_at": "2026-11-07T06:27:22+00:00", "cites": ["https://www.ibm.com/support/pages/node/7295637", "https://www.ibm.com/support/pages/node/7295635"]}]
exploit_sources: []
---

# IBM API Connect: stored XSS lets a logged-in user run scripts in others' browsers

Link for people: https://infrastack.ai/live/CVE-2026-16709 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not neutralize user input when a web page is updated. An authenticated attacker can get script content to run in another user's browser session.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13
- vendor:API Connect affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Find your API Connect version (management/Cloud Manager console or your deployment's installed version). Exposed if it is 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. Fixed in 10.0.8.13 and 12.1.1.3.

## Fix

Upgrade API Connect 10.0.8.x to 10.0.8.13, and 12.1.x to v12.1.1.3 (IBM bulletins). IBM lists no workaround for the 10.0.8 branch.

## Timeline

- 2026-11-07T05:45:57+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-16709
- 2026-11-07T06:27:22+00:00 analyst https://www.ibm.com/support/pages/node/7295637 — IBM bulletin node/7295637 lists CVE-2026-16709 (CWE-79, 8.7): affected V10.0.8.0-10.0.8.12, fix 10.0.8.13, workarounds none. Bulletin node/7295635 lists it too, fix v12.1.1.3 per its summary; its 12.1 affected-versions section was past the truncated page, so the 12.1 range comes from NVD. No exploitation or PoC found.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/node/7295637
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/node/7295635

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary JavaScript in the victim's browser due to cross-site scripting. User-supplied input is not properly neutralized when a web page is updated, so script content could run in another user's session.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
