---
id: "CVE-2026-17401"
page: "https://infrastack.ai/live/CVE-2026-17401"
kind: "vulnerability"
aliases: ["CVE-2026-17401"]
title: "IBM API Connect: stack buffer overflow lets signed-in attacker run code"
severity: "high"
cvss: 7.2
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "API Connect", "fixed": ["10.0.8.13", "12.1.1.3"], "affected": ">= 10.0.8.0, <= 10.0.8.12 || >= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "authenticated", "ibm-api-connect", "self-hosted", "vendor"]
not_affected_if: ["version-outside-affected-ranges"]
published_at: "2026-11-07T05:18:56+00:00"
first_seen_at: "2026-11-07T05:46:07+00:00"
updated_at: "2026-11-07T06:05:53+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17401", "first_seen_at": "2026-11-07T05:46:07+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:05:53+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41"]}]
exploit_sources: []
---

# IBM API Connect: stack buffer overflow lets signed-in attacker run code

Link for people: https://infrastack.ai/live/CVE-2026-17401 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a stack-based buffer overflow. A remote attacker with a valid account could exploit it to execute arbitrary code.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect affected >= 10.0.8.0, <= 10.0.8.12 || >= 12.1.0.0, <= 12.1.1.2 fixed 10.0.8.13, 12.1.1.3

## How to check

Check your installed API Connect version. Affected: 10.0.8.0 through 10.0.8.12, and 12.1.0.0 through 12.1.1.2 (IBM lists these as API Connect V12 OnPrem). Fixed: 10.0.8.13 and 12.1.1.3.

## Fix

Upgrade API Connect V12 to 12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205), or the 10.0.8 line to 10.0.8.13. IBM lists no workaround.

## Timeline

- 2026-11-07T05:46:07+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17401
- 2026-11-07T06:05:53+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — Both IBM bulletins (-39 for V12, -41 for 10.0.8) list CVE-2026-17401 (CWE-121, CVSS 7.2, PR:H). Fix: 12.1.1.3 / 10.0.8.13; workarounds: None. IBM gives no component or setting. -41 metadata says 10.0.8.0-10.0.8.13 but its table says through 10.0.8.12.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code due to a stack-based buffer overflow.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
