API CONNECT V12 ONPREM · CVE-2026-17332 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 do not validate certificates properly. A remote attacker can use this to bypass security restrictions.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect V12 OnPrem at v12.1.0.0 to v12.1.1.2. IBM describes a remote, unauthenticated attacker bypassing security restrictions through improper certificate validation (CWE-295); attack complexity is rated high. IBM's bulletin lists only V12 OnPrem as affected, so the 10.0.8.x line is not listed for this CVE.
Not affected if unknown
Who cares api-gateway, ibm-api-connect, on-prem, self-hosted
v12.1.0.0 through v12.1.1.2 are affected, v12.1.1.3 contains the fixIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to bypass security restrictions due to improper certificate validation.
This page as .md · .json · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (IBM Fix Central: https://www.ibm.com/support/pages/node/7290205).