API CONNECT · CVE-2026-17380 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 fail to validate a path parameter in requests. An authenticated user can read sensitive information belonging to other tenants.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running IBM API Connect (self-managed 10.0.8.x or V12 OnPrem 12.1.x) that host more than one tenant or organization. Any authenticated user can send a request with an unvalidated path value and read another tenant's data. Single-tenant installs have less exposure but should still upgrade.
Not affected if auth-required, single-tenant, versions-outside-range
Who cares api-gateway, auth-required, ibm-api-connect, multi-tenant, self-hosted
10.0.8.0 through 10.0.8.12 and V12 OnPrem 12.1.0.0 through 12.1.1.210.0.8.13 and IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to access sensitive information belonging to other tenants due to improper validation of a path parameter. A path value in a request is not sufficiently validated, which could allow a user to reach data outside their own tenant.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.x to 10.0.8.13, or 12.1.x (V12 OnPrem) to 12.1.1.3