---
id: "CVE-2026-17332"
page: "https://infrastack.ai/live/CVE-2026-17332"
kind: "vulnerability"
aliases: ["CVE-2026-17332"]
title: "IBM API Connect: improper certificate validation lets remote attackers bypass restrictions"
severity: "high"
cvss: 8.7
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "ibm-api-connect", "infrastructure", "on-prem", "self-hosted"]
not_affected_if: ["unknown"]
published_at: "2026-11-07T05:18:43+00:00"
first_seen_at: "2026-11-07T05:46:04+00:00"
updated_at: "2026-11-07T06:16:23+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17332", "first_seen_at": "2026-11-07T05:46:04+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:16:23+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect: improper certificate validation lets remote attackers bypass restrictions

Link for people: https://infrastack.ai/live/CVE-2026-17332 (this .md is for agents)

IBM API Connect versions 12.1.0.0 through 12.1.1.2 do not validate certificates properly. A remote attacker can use this to bypass security restrictions.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect V12 OnPrem version; versions v12.1.0.0 through v12.1.1.2 are affected, v12.1.1.3 contains the fix. IBM's bulletin does not name a command or file.

## Fix

Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (IBM Fix Central: https://www.ibm.com/support/pages/node/7290205).

## Timeline

- 2026-11-07T05:46:04+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17332
- 2026-11-07T06:16:23+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — IBM bulletin (-39, published 2026-11-05) lists CVE-2026-17332, CVSS 8.7, CWE-295; fix v12.1.1.3; IBM states no workarounds. No exploitation or PoC reported in the bulletin; did not search social.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to bypass security restrictions due to improper certificate validation.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
