API CONNECT · CVE-2026-17379 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not properly verify cryptographic signatures. A remote attacker can bypass authentication and assign themselves arbitrary roles.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0 to 10.0.8.12 or v12 OnPrem 12.1.0.0 to 12.1.1.2. An unauthenticated remote attacker can bypass authentication and assign arbitrary roles because cryptographic signatures are not verified properly; IBM rates it high (7.4) with high attack complexity. IBM lists no configuration condition and no workaround. Installs already on 10.0.8.13 or 12.1.1.3 or later can skip it.
Not affected if version-outside-range
Who cares api-gateway, ibm-api-connect, self-hosted
10.0.8.0 to 10.0.8.12 or to (IBM lists V12 OnPrem for the 12.x range)IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to bypass authentication and assign arbitrary roles due to improper verification of cryptographic signatures.
This page as .md · .json · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.0.012.1.1.210.0.8.13 or 12.1.1.3 and laterUpgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8.x line) or v12.1.1.3 (v12 line)