API CONNECT V12 ONPREM · CVE-2026-17327 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM says API Connect could let a remote authenticated attacker obtain sensitive information through server-side request forgery (CWE-918, CVSS 8.5). It affects V12 OnPrem v12.1.0.0-v12.1.1.2 and is fixed in v12.1.1.3. IBM lists no workarounds.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
IBM API Connect deployments in the 12.1.0.0 to 12.1.1.2 range are exposed to an authenticated remote attacker. Teams running API Connect outside that range are not affected by this entry. The sources do not describe the specific configuration or endpoint involved.
Not affected if auth-required, outside-affected-range
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 is fixedIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)